NeOn: Lifecycle Support for Networked Ontologies
Integrated Project (IST-2005-027595)
Priority: IST-2004-2.4.7 – “Semantic-based knowledge and content systems”

D6.7.1 Beta release of the Core NeOn Online Documentation

Deliverable Co-ordinator: Michael Erdmann
Deliverable Co-ordinating Institution: Ontoprise GmbH (ONGO)
Other Authors: Thomas Hemp (ONGO)

This document contains the first version of the online documentation for the NeOn Toolkit. The original deliverable consists of a set of HTML pages which are integrated into the toolkit as an Eclipse Help-plug-in. This document simply reproduces the same content in linear form as a Word document.

<table>
<thead>
<tr>
<th>Document Identifier</th>
<th>NEON/2007/D6.7.1/v1.2</th>
<th>Date due:</th>
<th>August 31, 2007</th>
</tr>
</thead>
<tbody>
<tr>
<td>Class Deliverable:</td>
<td>NEON EU-IST-2005-027595</td>
<td>Submission date:</td>
<td>August 31, 2007</td>
</tr>
<tr>
<td>Project start date:</td>
<td>March 1, 2006</td>
<td>Version:</td>
<td>v1.2</td>
</tr>
<tr>
<td>Project duration:</td>
<td>4 years</td>
<td>State:</td>
<td>Final</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Distribution:</td>
<td>Public</td>
</tr>
</tbody>
</table>
NeOn Consortium

This document is a part of the NeOn research project funded by the IST Programme of the Commission of the European Communities by the grant number IST-2005-027595. The following partners are involved in the project:

<table>
<thead>
<tr>
<th>Open University (OU) – Coordinator</th>
<th>Universität Karlsruhe – TH (UKARL)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Knowledge Media Institute – KMi</td>
<td></td>
</tr>
<tr>
<td>Berrill Building, Walton Hall</td>
<td></td>
</tr>
<tr>
<td>Milton Keynes, MK7 6AA</td>
<td></td>
</tr>
<tr>
<td>United Kingdom</td>
<td></td>
</tr>
<tr>
<td>Contact person: Martin Dzbor, Enrico Motta</td>
<td></td>
</tr>
<tr>
<td>E-mail address: {m.dzbor, e.motta} @open.ac.uk</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Institut für Angewandte Informatik und Formale Beschreibungsverfahren – AIFB</td>
</tr>
<tr>
<td></td>
<td>Englerstrasse 28</td>
</tr>
<tr>
<td></td>
<td>D-76128 Karlsruhe, Germany</td>
</tr>
<tr>
<td></td>
<td>Contact person: Peter Haase</td>
</tr>
<tr>
<td></td>
<td>E-mail address: <a href="mailto:pha@aifb.uni-karlsruhe.de">pha@aifb.uni-karlsruhe.de</a></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Universidad Politécnica de Madrid (UPM)</th>
<th>Software AG (SAG)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Campus de Montegancedo</td>
<td></td>
</tr>
<tr>
<td>28660 Boadilla del Monte</td>
<td></td>
</tr>
<tr>
<td>Spain</td>
<td></td>
</tr>
<tr>
<td>Contact person: Asunción Gómez Pérez</td>
<td></td>
</tr>
<tr>
<td>E-mail address: <a href="mailto:asun@fi.upm.es">asun@fi.upm.es</a></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Intelligent Software Components S.A. (ISOCO)</td>
<td>Institut ‘Jožef Stefan’ (JSI)</td>
</tr>
<tr>
<td>Calle de Pedro de Valdivia 10</td>
<td>Jamova 39</td>
</tr>
<tr>
<td>28006 Madrid</td>
<td>SI-1000 Ljubljana</td>
</tr>
<tr>
<td>Spain</td>
<td>Slovenia</td>
</tr>
<tr>
<td>Contact person: Jesús Contreras</td>
<td>Contact person: Marko Grobelnik</td>
</tr>
<tr>
<td>E-mail address: <a href="mailto:jcontreras@isoco.com">jcontreras@isoco.com</a></td>
<td>E-mail address: <a href="mailto:marko.grobelnik@jsi.si">marko.grobelnik@jsi.si</a></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Institut National de Recherche en Informatique et en Automatique (INRIA)</th>
<th>University of Sheffield (USFD)</th>
</tr>
</thead>
<tbody>
<tr>
<td>ZIRST – 655 avenue de l’Europe</td>
<td>Dept. of Computer Science</td>
</tr>
<tr>
<td>Montbonnot Saint Martin</td>
<td>Regent Court</td>
</tr>
<tr>
<td>38334 Saint-Ismier</td>
<td>211 Portobello street</td>
</tr>
<tr>
<td>France</td>
<td>S14DP Sheffield</td>
</tr>
<tr>
<td>Contact person: Jérôme Euzenat</td>
<td>United Kingdom</td>
</tr>
<tr>
<td>E-mail address: <a href="mailto:Jerome.euzenat@inrialpes.fr">Jerome.euzenat@inrialpes.fr</a></td>
<td>Contact person: Hamish Cunningham</td>
</tr>
<tr>
<td></td>
<td>E-mail address: <a href="mailto:hamish@dcs.shef.ac.uk">hamish@dcs.shef.ac.uk</a></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Universität Koblenz-Landau (UKO-LD)</td>
<td>Consiglio Nazionale delle Ricerche (CNR)</td>
</tr>
<tr>
<td>Universitätsstrasse 1</td>
<td>Institute of cognitive sciences and technologies</td>
</tr>
<tr>
<td>56070 Koblenz</td>
<td>Via S. Martino della Battaglia,</td>
</tr>
<tr>
<td>Germany</td>
<td>44 - 00185 Roma-Lazio, Italy</td>
</tr>
<tr>
<td>Contact person: Steffen Staab</td>
<td>Contact person: Aldo Gangemi</td>
</tr>
<tr>
<td>E-mail address: <a href="mailto:staab@uni-koblenz.de">staab@uni-koblenz.de</a></td>
<td>E-mail address: <a href="mailto:aldo.gangemi@istc.cnr.it">aldo.gangemi@istc.cnr.it</a></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Ontoprise GmbH. (ONTO)</th>
<th>Food and Agriculture Organization of the United Nations (FAO)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Amalienbadstr. 36 (Raumfabrik 29)</td>
<td>Viale delle Terme di Caracalla 1</td>
</tr>
<tr>
<td>76227 Karlsruhe</td>
<td>00100 Rome</td>
</tr>
<tr>
<td>Germany</td>
<td>Italy</td>
</tr>
<tr>
<td>Contact person: Jürgen Angele</td>
<td>Contact person: Marta Iglesias</td>
</tr>
<tr>
<td>E-mail address: <a href="mailto:angele@ontoprise.de">angele@ontoprise.de</a></td>
<td>E-mail address: <a href="mailto:marta.iglesias@fao.org">marta.iglesias@fao.org</a></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Atos Origin S.A. (ATOS)</th>
<th>Laboratorios KIN, S.A. (KIN)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calle de Albarracín, 25</td>
<td>C/Ciudad de Granada, 123</td>
</tr>
<tr>
<td>28037 Madrid</td>
<td>08018 Barcelona</td>
</tr>
<tr>
<td>Spain</td>
<td>Spain</td>
</tr>
<tr>
<td>Contact person: Tomás Pariente Lobo</td>
<td>Contact person: Antonio López</td>
</tr>
<tr>
<td>E-mail address: <a href="mailto:tomas.parientelobo@atosorigin.com">tomas.parientelobo@atosorigin.com</a></td>
<td>E-mail address: <a href="mailto:alopez@kin.es">alopez@kin.es</a></td>
</tr>
</tbody>
</table>
Work package participants

The following partners have taken an active part in the work leading to the production of this document, even if they might not have directly contributed to writing parts of this document:

Ontoprise GmbH
Change Log

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Amended by</th>
<th>Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.1</td>
<td>2007-07-01</td>
<td>Thomas Hemp</td>
<td>Initial Version as Word Document</td>
</tr>
<tr>
<td>0.2</td>
<td>2007-08-01</td>
<td>Michael Erdmann</td>
<td>Split documentation into parts for online reading</td>
</tr>
<tr>
<td>0.3</td>
<td>2007-08-14</td>
<td>Michael Erdmann</td>
<td>Finalized separate documents in word. Integrated for review process</td>
</tr>
<tr>
<td>1.0</td>
<td>2007-08-15</td>
<td>Michael Erdmann</td>
<td>Integrated document for review process, sent to Klaas Dellschaft</td>
</tr>
<tr>
<td>1.1</td>
<td>2007-08-29</td>
<td>Michael Erdmann</td>
<td>Integration of review feedback by Klaas Dellschaft</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Final version</td>
</tr>
<tr>
<td>1.2</td>
<td>2007-09-11</td>
<td>Angela Wilkinson</td>
<td>QA</td>
</tr>
</tbody>
</table>

Executive Summary

This document contains the first version of the online documentation for the NeOn Toolkit. The original deliverable consists of a set of HTML pages which are integrated into the toolkit as an Eclipse Help-plug-in. This document simply reproduces the same content in linear form as a Word document.
Table of Contents

NeOn Consortium ..................................................................................................................................... 2
Work package participants .................................................................................................................. 3
Change Log ......................................................................................................................................... 4
Executive Summary........................................................................................................................... 4
Table of Contents............................................................................................................................... 5
List of Tables ....................................................................................................................................... 6
List of Figures ..................................................................................................................................... 6
Introduction ......................................................................................................................................... 8

1. Basics of NeOn Toolkit .................................................................................................................. 9
   1.1. Starting NeOn Toolkit .............................................................................................................. 9
   1.2. Hot Keys .................................................................................................................................. 10
   1.3. The User Interface ................................................................................................................... 11
   1.4. Perspectives ............................................................................................................................ 12
   1.5. NeOn Toolkit Menus ............................................................................................................... 13
      1.5.1. The “File” Menu .............................................................................................................. 13
      1.5.2. The “Edit” Menu ........................................................................................................... 15
      1.5.3. The “Navigate” Menu .................................................................................................... 15
      1.5.4. The “Search” Menu ........................................................................................................ 15
      1.5.5. The “Window” Menu ..................................................................................................... 16
      1.5.6. The “Help” Menu .......................................................................................................... 17
   1.6. The Tool Bar of NeOn Toolkit ............................................................................................... 18
   1.7. Importing Ontologies ............................................................................................................ 19
      1.7.1. Supported Import Formats ............................................................................................. 20
      1.7.2. File System Import ........................................................................................................ 20
   1.8. Exporting Ontologies ............................................................................................................ 19
      1.8.1. Supported Export Filters ............................................................................................... 22
      1.8.2. File System Export ......................................................................................................... 22
   1.9. Localization of Ontologies .................................................................................................... 22
   1.10. How to exit NeOn Toolkit ..................................................................................................... 23

2. Ontology Modelling ....................................................................................................................... 25
   2.1. Schema Perspective ................................................................................................................. 25
   2.2. The Ontology Navigator ......................................................................................................... 26
   2.3. Entity Properties View for Concepts ....................................................................................... 28
   2.4. Entity Properties View for Relations ....................................................................................... 29
   2.5. Entity Properties View for Attributes ..................................................................................... 31
   2.6. Instance View .......................................................................................................................... 32
      2.6.1. Defining a New Instance ................................................................................................. 32
      2.6.2. Deleting Instances .......................................................................................................... 32
      2.6.3. Moving Instances ........................................................................................................... 32
      2.6.4. Properties of Instances .................................................................................................. 33
   2.7. Namespace Handling ................................................................................................................ 34
   2.8. Synonym View ........................................................................................................................ 34

3. Visualizing Ontologies .................................................................................................................. 36
   3.1. Ontology Graph Visualize View ............................................................................................. 36
      3.1.1. Concept in Focus ............................................................................................................. 37
      3.1.2. Navigation history ......................................................................................................... 37
      3.1.3. Legend ............................................................................................................................ 37
      3.1.4. Graph elements ............................................................................................................... 37
      3.1.5. Other Functions .............................................................................................................. 38
   3.2. Graph View ............................................................................................................................. 38

2007 © Copyright lies with the respective authors and their institutions.
4. Rules .................................................................................................................................................. 40
   4.1. Creating a Rule .......................................................................................................................... 40
   4.2. Entity Property View for Rules ................................................................................................. 40
   4.3. Textually Property Editing Rules ............................................................................................. 41
   4.4. Graphical Rule Editor ................................................................................................................. 43
       4.4.1. Overview .......................................................................................................................... 43
       4.4.2. Adding Concepts and Instances to the GRE .................................................................. 43
       4.4.3. Adding Attributes to the GRE ......................................................................................... 43
       4.4.4. Adding Predicates to the GRE .......................................................................................... 43
       4.4.5. Adding Relations or Attributes to the GRE ................................................................. 44
       4.4.6. Adding a Comparison ....................................................................................................... 44
       4.4.7. Specifying Head and Body Parts ...................................................................................... 45
       4.4.8. Negations .......................................................................................................................... 45
       4.4.9. The Palette Menu ............................................................................................................. 45
       4.4.10. The Context Menu .......................................................................................................... 46
   4.5. Stylized English View ................................................................................................................. 47
5. Sample Walkthrough ......................................................................................................................... 48
   5.1. First Steps .................................................................................................................................. 48
   5.2. Creating a New Ontology .......................................................................................................... 49
   5.3. Creating New Concepts .......................................................................................................... 50
   5.4. Multilingual Representations .................................................................................................. 51
   5.5. Creating Attributes .................................................................................................................. 51
   5.6. Creating Relations .................................................................................................................... 52
   5.7. Setting up Instances ................................................................................................................. 53
   5.8. Moving a Concept ..................................................................................................................... 53

List of Tables

   Table 1 - Hot Keys and functions ................................................................................................. 10
   Table 2 - Concept Property Descriptions .................................................................................... 28
   Table 3 - Example relations ........................................................................................................ 29
   Table 4 - Relations Property Descriptions .................................................................................. 30
   Table 5 - Attributes Property Descriptions .................................................................................. 31
   Table 6 - Sample Multilingual representations ........................................................................... 51

List of Figures

   The selection of the workspace directory .................................................................................... 9
   Start screen of NeOn Toolkit – Schema Perspective .................................................................... 10
   The user interface of NeOn Toolkit (here: “Schema Perspective”) ............................................. 12
   Button to display and change the main perspectives .................................................................. 13
   The “File” menu .......................................................................................................................... 13
   Creating a new ontology project .................................................................................................. 14
   The “Search” menu ...................................................................................................................... 15
   The “Search” dialog ...................................................................................................................... 15
   The “Search – Result” dialog ........................................................................................................ 16
   The “Window” menu .................................................................................................................... 16
   The “Preferences” menu .............................................................................................................. 17
   The “About” window ..................................................................................................................... 18
   The symbol bar ............................................................................................................................. 18
   The menu window “File – Import…” and the context menu of an element .................................. 19
   The “File – Import…” View ......................................................................................................... 20
   Dialog “FileSystem Ontology Import” ......................................................................................... 21
   Dialog “Export File System” ........................................................................................................ 22
The “Preferences” menu to create or change the language ................................................................. 23
The “Confirm Exit” window .................................................................................................................. 23
The menu “Save Ontologies” .................................................................................................................. 24
The “Schema” Perspective .................................................................................................................... 26
The “Ontology Navigator” view of an ontology ....................................................................................... 27
“Entity Properties View” for concepts .................................................................................................. 28
“Entity Properties View” for relations .................................................................................................. 30
“Entity Properties View” for attributes ............................................................................................... 31
“Instance View” .................................................................................................................................... 32
Menu – “Move instances” ...................................................................................................................... 33
“Properties View” .................................................................................................................................. 33
Multi select dialog ................................................................................................................................. 34
“Entity Properties View” of ontologies ................................................................................................. 34
“Synonym View” ................................................................................................................................... 34
“Synonym Editor” ................................................................................................................................. 35
Context menu to initiate the ontology graph visualizer .......................................................................... 36
“Ontology Graph Visualizer” .................................................................................................................. 37
“OntoVisualize Preferences” ................................................................................................................ 37
Context menu of the “Ontology Graph Visualize View” ......................................................................... 38
Select “Graph View” ............................................................................................................................. 39
Settings for the “Graph View” ............................................................................................................... 39
“Graph View with Template Concept Graph” ....................................................................................... 39
Context menu “New Rule” ..................................................................................................................... 40
“Entity Property View” for Rules .......................................................................................................... 41
“Rule” Register Tab ................................................................................................................................. 41
Textual view of a rule in its “Entity Properties View” ........................................................................ 42
“Textual Edit …” view ............................................................................................................................ 42
Graphical representation of a rule in its “Entity Properties View” ........................................................ 43
The selection list of a predicate ............................................................................................................... 44
Choosing the comparator of an attribute connection ........................................................................... 44
Menu “Palette” ........................................................................................................................................ 45
Workflow functions of the GRE desktop ................................................................................................. 46
Creating a new project ............................................................................................................................ 48
Creating a new Ontology Development Project .................................................................................... 48
Create a new project named “cars” ....................................................................................................... 49
Basic structure of the ontology .............................................................................................................. 50
Concepts and sub concepts .................................................................................................................... 51
German representation “Produkt” for the concept “product” .................................................................. 51
Properties (attributes and relations) of the concept “region” ................................................................ 52
“Instance View” window ....................................................................................................................... 53
“Properties” window, e.g. the value “North America” in the attribute field “hasName” ....................... 53
Menu – Moving a concept ..................................................................................................................... 54
“Move concepts” dialog to choose the target concept .......................................................................... 54
Introduction

This document represents the first iteration of the online documentation of the NeOn Toolkit. Since the online documentation actually consists of a set of HTML pages that are available from within the toolkit and can be accessed interactively, here we can only present a version of the content in a more linear form.

Each top-level section of this document will be presented as a top-level node in the table of content of the on-line help system within the NeOn Toolkit. All second and third-level sections will be represented in the on-line help as individual web pages accessible from a built-in web browser.
1. Basics of NeOn Toolkit

1.1. Starting NeOn Toolkit

You can start NeOn Toolkit using one of these two methods:

- Click on the NeOn Toolkit icon on the desktop or
- Select in the Windows start menu: Start > All Programs > NeOn Toolkit Version 1.0 > NeOn Toolkit 1.0

At the first start of the program the “Workspace Launcher” window is loaded. There you can specify your workspace directory:

The selection of the workspace directory

In this dialog window you can select the directory in which NeOn Toolkit will save all its appropriate data. In order to save the data in a directory other than the specified one, click on the Browse... button and select the desired directory. Confirm with OK to start the application. The program starts and the start screen appears:
1.2. Hot Keys

Apart from the usual hot keys, there are additional key combinations that allow for rapid and comfortable changing between the different views and editors, in order to simplify the navigation in NeOn Toolkit. They are listed in the following table.

**Table 1 - Hot Keys and functions**

<table>
<thead>
<tr>
<th>Hot key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong>: Hot keys to create new data, projects, ontologies, etc.</td>
<td></td>
</tr>
<tr>
<td>Alt + Shift + N</td>
<td>Menu: Create a new project</td>
</tr>
<tr>
<td>Ctrl + N</td>
<td>Menu: File - New</td>
</tr>
<tr>
<td>F5</td>
<td>Refresh: to actualize the view</td>
</tr>
<tr>
<td><strong>Edit</strong>: Hot keys to edit the components</td>
<td></td>
</tr>
<tr>
<td>Ctrl + X</td>
<td>Cut the marked text</td>
</tr>
</tbody>
</table>
### Ctrl + C
Copy the marked text

### Ctrl + V
Insert the text which is stored in the buffer

### Del / Delete
Delete the marked text

#### Search: Hot keys to call the search function

### Ctrl + H
Open the search window

#### Window: Hot keys to change between the different menus

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALT + -</td>
<td>Show the System Menu for the active view with the following activities: Fast View, Restore, Move, Size, Minimize, Maximize, Close</td>
</tr>
<tr>
<td>Ctrl + F10</td>
<td>Show the current view menu</td>
</tr>
<tr>
<td>Ctrl + M</td>
<td>Maximize the active view or the active editor</td>
</tr>
<tr>
<td>Ctrl + F7</td>
<td>Change to the next view</td>
</tr>
<tr>
<td>Ctrl + Shift + F7</td>
<td>Change to the previous view</td>
</tr>
<tr>
<td>Ctrl + F8</td>
<td>Change to the next perspective</td>
</tr>
<tr>
<td>Ctrl + Shift + F8</td>
<td>Change to the previous perspective</td>
</tr>
<tr>
<td>Ctrl + Shift + L</td>
<td>List of all implemented Eclipse short cuts</td>
</tr>
</tbody>
</table>

### 1.3. The User Interface

The user interface consists of a menu, a tool bar and the main area containing different so-called views for the actual content.
1. Menu bar and tool bar

While the menu bar controls most operations of NeOn Toolkit, the tool bar contains frequently used operations. For example, you can open the “Mapping View” with one click on the appropriate button.

2. Main area

As default, NeOn Toolkit starts with the “Schema Perspective” containing four different views: the “Ontology Navigator”, the “Entity Properties View”, the “Instance View” and the “Properties View”.

3. Status bar

The status bar at the bottom of the screen shows the current data model (usually set to RAM). Other data models that store models in a persistent data bases instead of in the main memory, are available.

1.4. Perspectives

The features of NeOn Toolkit are grouped in different so-called perspectives, such as the “Schema Perspective” or the “Mapping Perspective”. A perspective is a composition of different views to achieve a common task, e.g. the schema perspective contains views/tools for modeling ontologies.

On the right hand side of the toolbar you find the perspective selector which lets you switch between perspectives.
Currently NeOn Toolkit includes a couple of perspectives:

- The **Schema Perspective** - to display general views for creating, editing and deleting ontology objects such as concepts, attributes, relations, instances, rules, and queries. When starting NeOn Toolkit, the “Schema Perspective” is displayed by default.
- The **Mapping Perspective** - to map between different ontologies or certain parts of them.
- The **F-Logic Editor Perspective** - to edit a complete ontology by text in F-Logic.
- The **Debugging Perspective** - to run queries in a debug mode and give the user the possibility of tracing.

### 1.5. NeOn Toolkit Menus

#### 1.5.1. The “File” Menu

The “File” menu contains the standard operations of the program that are described below.

<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>Navigate</th>
<th>Search</th>
<th>Project</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>New</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close</td>
<td></td>
<td>Ctr+V</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close All</td>
<td></td>
<td>Ctr+Shift+V</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Save</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td></td>
<td>Ctr+S</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save As...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save All</td>
<td></td>
<td>Ctr+Shift+S</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Revert</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Move...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rename...</td>
<td></td>
<td>F2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Refresh...</td>
<td></td>
<td>F5</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print...</td>
<td></td>
<td></td>
<td></td>
<td>F10</td>
<td></td>
</tr>
<tr>
<td>Switch Workspace...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open Ontology...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save Ontology</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save Ontology As...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The “File” menu

- **File > New > Project > Ontology Project**
Creates a new ontology project: You must specify a project name that does not exist yet. If you want to add ontologies that already exist in other loaded projects, please click the ADD... button. Select the desired ontology in the following dialog. In order to remove an added ontology, mark this ontology and click the Remove button.

Creating a new ontology project

- **File > New > Other**
  Here you can create new elements, e.g., ontologies.

- **Refresh**
  Updates the user interface, e.g., arranges the ontology elements alphabetically in the ontology navigator.

- **Switch workspace**
  NeOn Toolkit stores your projects in a folder called a workspace. Choose a different workspace folder here to start a new session with the new workspace.

- **Import Wizard**
  Opens the import dialog to choose a wizard for importing ontologies or other data sources

- **Export Wizard**
  Opens the export dialog for writing ontologies in different formats

- **Open Ontology**
  Opens an ontology from a selected file; this is the same functionality as **File > Import > File System**
• **Save Ontology as…**
  Saves the currently selected ontology; represents the same functionality as *File > Export > File System*

• **Exit**
  Displays a dialog where you can save the changes to your ontologies before closing the application

### 1.5.2. The “Edit” Menu

This menu contains the usual functionality for cut, copy and paste as well as delete. These operations refer to the nodes in the ontology navigator.

### 1.5.3. The “Navigate” Menu

The menu entries of the “Navigate” Menu are currently disabled.

### 1.5.4. The “Search” Menu

With the “Search” menu you can search for elements in ontologies.

```
Search...  Ctrl+H
```

The “Search” menu

This opens the “Search” dialog. This dialog contains tabs for searching in files and for searching in ontologies. The file-search option is not functional since we operate on the conceptual ontology model, rather than on files storing the ontologies.
You can search concepts, attributes, relations and instances inside the selected ontology. The results will be shown in a result view, where you can double click the entities to jump to the appropriate location in the ontology navigator.

The "Search – Result" dialog

1.5.5. The “Window” Menu


The “Window” menu

- **Open Perspective**
  Opens the selection menu for perspectives
- **Show View**
  Opens the selection menu for different views
- **Customize Perspective**
  Opens the window to customize the different views
- **Save Perspective As …**
  Opens the window to save the current perspective under the chosen name
• **Reset Perspective**
  Deletes the preferences in the current perspective and restores the old preferences.

• **Close Perspective**
  Closes the activate perspective

• **Close All Perspectives**
  Closes all perspectives

• **Navigation**
  Allows switching between different editor windows, views and perspectives

• **Show Mapping View**
  The “Mapping View” is displayed

• **Show Entity Properties View**
  The “Entity Properties View” is displayed

• **Preferences**
  Opens the Eclipse standard preferences window. Some additional entries for NeOn Toolkit are available for the FLogic editor, language preferences, Ontology visualizer or the query tool. For a description of the other preferences refer to the Workbench user guide on the Eclipse website (cf. [http://help.eclipse.org/help32/index.jsp](http://help.eclipse.org/help32/index.jsp)).

---

**The “Preferences” menu**

1.5.6. The **“Help” Menu**

Select **Help > About** to get further information about NeOn Toolkit. The following window shows the used NeOn Toolkit version with the build ID, the contact data of ontoprise and the relevant copyright information. For further information follow the mentioned links.
The “About” window

- Plug-in Details:
  A list of installed plug-ins and their versions
- Configuration Details:
  A list of configuration details of the installed NeOn Toolkit version. Here you can also open the error log file.

1.6. The Tool Bar of NeOn Toolkit

The symbols of the tool bar allow quick access to some specific functions of NeOn Toolkit.

- New
  The New button opens the “New” wizard where you can create a new ontology. It has the same function as the menu item File > New
- Save
  disabled
- Print
  disabled
- Show Mapping View
  Opens the “Mapping View” window
- Show Entity Properties View
  Opens the “Entity Properties View” displaying details for different elements of the ontology
- Generate Graph
  Generates graph starting at the given concept
• **Create Concept**
  Creates a new concept in the current ontology. If a concept is selected, a sub-concept is created. If the concept folder is selected, a new root concept is created.

  A randomly generated name is proposed for the new concepts. In order to change the name directly, please enter a new name and then press Enter. The new concepts are not automatically arranged in alphabetic order, so to sort them alphabetically, open the context menu for the “Concepts” folder in the “Ontology Navigator” and select the “Refresh” menu item.

• **Show/Hide Namespaces**
  Switches the display of the namespaces to “on” / “off”

• **Search**
  Opens the “Search” window. Here you can search for elements in the selected ontology.

1.7. **Importing Ontologies**

Existing ontologies and other data structures such as database schemas can be loaded into NeOn Toolkit.

The menu window “File – Import...” and the context menu of an element

You can initiate the import process following the following instructions:

- **Select File > Import...** on the menu bar or
- Select the entry **Import...** with a right mouse click in the “Ontology Navigator” (the imported data source will be inserted into the project on which the import was applied)
- The “Import” window opens to select different import wizards. Select the type of data for the import and confirm the appropriate procedure with **Next**.

2007 © Copyright lies with the respective authors and their institutions.
1.7.1. Supported Import Formats

Currently we support

- Loading ontology files in different formats from the file system or a WebDAV server
- Translating a database schema from a relational database management system into an ontology
- Interpreting the folder structures and files from the file system as instances (FileSystem MetaData Import Wizard)

Some of these features are only supported by the extended configuration of NeOn Toolkit and not in the basic version.

1.7.2. File System Import

For importing ontologies from the local file system, the following input formats are available:

- F-Logic – Frame logic is a knowledge representation- and ontology language (extension .flo)
- OXML – An XML-based ontology definition language used by ontoprise GmbH (extension .oxml)
- OWL – The web ontology language of the W3C (extension .owl)
• RDF / RDF (S) – Resource Description Framework (Schema) of the W3C (extension .rdf or .rdfs for the XML serialization or .nt for N-Triple or .n3 for N3)

To trigger this import, select File > Import > OntoStudio > FileSystem Import Wizard and click on Next. The subsequent dialog lets you choose the location of the ontology (Browse button). You can also enter the location manually.

In the same dialog the drop down list “To project” refers to the project into which the ontology will be imported. After confirming with Finish the ontology will be imported. The selected ontology data source is imported from its location to the selected project and is now available within NeOn Toolkit.

1.8. Exporting Ontologies

The export function enables saving ontologies in different formats. For that purpose, you can use the corresponding menu items in the “File” menu.

You can export ontologies into the data formats F-Logic, OXML, OWL or RDF(s). If a project contains a number of ontologies (you can see this in the “Ontology Navigator” window), you must select the ontologies you wish to export by marking them specifically.

N.B.: Because of the differences of the ontology languages, information may be lost during the export process into the different formats, e.g. RDF-export rules which have been modeled are lost.

To initiate the export process from the “Ontology Navigator” select the ontology and open the context menu. Choose the entry Export… or choose this entry from the menu bar File > Export … In the following “Export” window select a destination to which the ontology will be exported (File System or WebDAV).

Export to File System

It is possible to export to every directory which is available in the local file system.

Export to WebDAV Repository

A WebDAV Repository is a kind of remote file system that supports versioning and other sophisticated features. Thus, ontologies can be stored under the same name several times, creating different releases of the same file.
1.8.1. Supported Export Filters

Currently we support the export of ontologies to the local file system or to a WebDAV repository using F-Logic, OXML, OWL or RDF(s). Also ontologies can be partially saved as UML class diagrams.

1.8.2. File System Export

For exporting ontologies to the local file system choose the File System Export Wizard in the Export menu and confirm with Next.

In the drop-down lists “Select project” and “Select ontology” choose the ontology to be exported. Click Browse to select a target file with a desired data type ("*.oxml", "*.flo", "*.rdfs", "*.owl") and confirm with Finish. NeOn Toolkit will write the file to disk. Depending on the size of the ontology and the chosen format, the export process can take some time.

1.9. Localization of Ontologies

Within the language preferences you can specify the languages you want to develop your ontology for. To open the language preferences go to the Window menu, and select Preferences > Language Preferences. The fields for documentation and representation then let you input values for these languages. All languages according to ISO standard are supported!
The “Preferences” menu to create or change the language

Mark the entries and push the **Up** or **Down** button to change the order. Create a new locale by clicking on the **Create** button.

**1.10. How to exit NeOn Toolkit**

If you want to exit NeOn Toolkit, select **File > Exit...** in the menu bar and confirm with **OK**. The “Confirm Exit” dialogue appears. Here you can set the checkmark “Always exit without prompt”, in order to terminate NeOn Toolkit without being asked again.

The “Confirm Exit” window
If you created a new ontology, you will be asked where you want to store it. Click on the *Don’t Save*, *Save* or *Cancel* button.

The menu “Save Ontologies”

The application will be terminated.
2. Ontology Modelling

Creating a domain model requires creating a basic ontology, integrating existing information, eliciting knowledge from domain experts and formalizing it as rules. So the modelling process can be divided into four phases:

- the analysis of the domain
- the construction of the ontology
- the integration of already existing facts in databases
- the modelling of the expert knowledge as rules

The initial step in the modelling process is the analysis of the domain. It is necessary to exactly define the domain; this can be a challenging task because the domain experts are in most cases not able to develop an ontology and the knowledge engineers do not have sufficient knowledge of the domain. To complete this task a knowledge transfer has to be done from the domain experts to the knowledge engineers.

The resulting system is based on an ontology. This ontology has two major objectives. Firstly it represents the terminology and the complex dependencies between the different domain parts. These dependencies are represented as relationships and rules. Secondly the ontology serves as a mediator between data from different sources, for example to integrate up-to-date data about special domain parts etc.

After the identification of the terms and properties of the domain, the modelling phase starts. From here on, NeOn Toolkit supports the whole engineering process, from the creation of the ontology to the development of the expert rules. At first you will create domain concepts and arrange them in a subsumption hierarchy. Afterwards attributes and relations will be added to the model and finally it will be completed with rules, although this is not the only possible sequence; lots of iterations are normal. The basic means for creating ontological knowledge is the schema-perspective.

2.1. Schema Perspective

By default, the Schema Perspective is split into four separate areas ("views"):  
- "Ontology Navigator" (the tree representation in the top left)  
- "Entity Properties View" (top right)  
- "Instance View" (the list in the bottom left)  
- "Properties View" (to table in the bottom right)
2.2. The Ontology Navigator

In the “Ontology Navigator” the different ontology projects and their corresponding ontologies are displayed. You can navigate through the elements in the same way as “Windows Explorer” and you can also create, change and delete the ontology elements. The editing possibilities of each element are listed in its context menu (To open an element’s context menu, right-click on the appropriate).

If an element contains further sub elements, then a plus sign is displayed on its left side, click on this to display the sub elements. In order to close the sub element view, click on the minus sign of the parent element.

Rules are stored in the “Rules” folder. You can create new rules here and with the appropriate context menu, you can also create your own rule subfolders to organise these rules.

Queries can be found in the “Queries” folder, and mappings in the “Mappings” folder.
The "Ontology Navigator" view of an ontology

For the different elements in the ontology navigator, Property Views exist that display details and allow them to be edited. There are different "Entity Properties Views" for:

- concepts
- relations
- attributes
- rules
- queries
- mappings

The entity types rules, queries, and mappings are only available in the extended configuration of NeOn Toolkit and not in the basic version.
2.3. Entity Properties View for Concepts

In the “Entity Properties View” for concepts you can edit all properties of a concept. The table below explains all the different areas of the panel.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the concept can be changed here. All changes will also be displayed in the hierarchy of the “Schema View”.</td>
</tr>
<tr>
<td>Namespace</td>
<td>Namespace (URI) of the concept.</td>
</tr>
<tr>
<td>Attributes</td>
<td>In this area you can create attributes for your concept by entering the name of the attribute in the “Attribute” column. Enter the range of values (String, Double, Boolean, Integer) in the “Range” column. All entries are then confirmed by pressing the Enter button. With “Min” and “Max” you can define the cardinality of the attribute. You can delete an attribute with the red cross at the end of the line. Grey shaded attributes are inherited and can only be changed in the super-concept. In addition, all attributes will be displayed in the attributes folder in the “Schema View” where you can also rename them.</td>
</tr>
</tbody>
</table>
### Property | Description
--- | ---
Relations | Here you can define relations, which describe the dependencies between concepts. Enter the name of the relation in the “Relation” column. “Range” defines the other concept you want to relate to the active concept. All entries are confirmed by pressing Enter. “Min” and “Max” define the cardinality. The red cross deletes the selected relation. Grey shaded relations are inherited and can only be changed in the super concept.

### Description | Textual documentation of the concept can be written in the description field. Multiple languages are supported; by default, the documentation can be done in English, German and French, but you can also add new languages with the NeOn Toolkit preferences.

### Representations | A textual representation of the concept name in multiple languages.

The following table presents some examples for the different cardinalities of relations:

#### Table 3 - Example relations

<table>
<thead>
<tr>
<th>min</th>
<th>max</th>
<th>- Column</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>exactly one value (e.g. birth date)</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>none or one value (husband)</td>
</tr>
<tr>
<td>0</td>
<td>N</td>
<td>no value or optional number of values (children)</td>
</tr>
<tr>
<td>1</td>
<td>N</td>
<td>at least one value required or optional number of values (first name)</td>
</tr>
</tbody>
</table>

### 2.4. Entity Properties View for Relations

Relations are created within the context of a concept, but they can be edited starting from the relation folder of the Ontology Navigator. To open the “Entity Properties View” for a relation, select the relation in the “Ontology Navigator”. This view displays information about the relations - all relations with the same name are displayed in one “Properties View”.

---

2007 © Copyright lies with the respective authors and their institutions.
“Entity Properties View” for relations

Table 4 - Relations Property Descriptions

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the relation can be changed here. All changes will also be displayed in the “Schema View” hierarchy.</td>
</tr>
<tr>
<td>Namespace</td>
<td><em>Namespace (URI)</em> of the relation.</td>
</tr>
<tr>
<td>Local relations</td>
<td>“Domain” and “Range” define the concepts connected by the relation. You can enter new concepts in the “Domain” column. “Min” and “Max” define the cardinalities of the relation. The columns “symmetric” and “transitive” define whether the relations are symmetric or transitive. The red cross deletes the local relation between the two concepts.</td>
</tr>
<tr>
<td>Description</td>
<td>Textual documentation of the relation can be written in the description field. Multiple languages are supported, by default, the documentation can be done in English, German and French, but you can also add new languages with the NeOn Toolkit preferences.</td>
</tr>
<tr>
<td>Representations</td>
<td>A textual representation of the relation name in multiple languages.</td>
</tr>
<tr>
<td>Inverse relations</td>
<td>The “Inverse” column lists the relations that are inverse to the active relation.</td>
</tr>
</tbody>
</table>
2.5. Entity Properties View for Attributes

Essentially, the entities properties view for attributes behaves in exactly the same way as for relations. The main difference is the restriction to only built-in types for the range field of attributes.

![Table 5 - Attributes Property Descriptions]

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the attribute. Can be changed here. All changes will also be displayed in the hierarchy of the “Schema View”.</td>
</tr>
<tr>
<td>Namespace</td>
<td><em>Namespace (URI)</em> of the attribute</td>
</tr>
<tr>
<td>Local relations</td>
<td>The “Domain” column displays the name of the concept for which the attribute is defined. New concepts can be added here as well. The type of the attribute (String, Double, Integer, Boolean) can be entered in the “Range” column.</td>
</tr>
<tr>
<td>Description</td>
<td>Textual documentation of the attribute can be written in the description field. Multiple languages are supported; by default, the documentation can be done in English, German and French, but you can also add new languages with the NeOn Toolkit preferences.</td>
</tr>
<tr>
<td>Representations</td>
<td>A textual representation of the attribute name in multiple languages.</td>
</tr>
</tbody>
</table>

"Entity Properties View” for attributes
2.6. Instance View

All existing instances for a concept will be shown in the instance view. New instances can be created, remove and deleted.

![Instance View]

"Instance View"

2.6.1. Defining a New Instance

- Select the concept for you want to create an instance for, by clicking on it in the “Ontology Navigator” window.
- Right click in the “Instance View” to bring up the context menu and select “New Instance” from the options available, or
- click on the symbol in the title line of “Instance View”
- In the “Instance View” window a new instance is displayed, with a randomly generated name, e.g.: “instance1106663037379”.

**We recommend giving new instances an expressive name to be able to recognize them later in the ontology.**

2.6.2. Deleting Instances

To delete an instance select it with a right mouse click and choose “Delete Instance” from the context menu. Alternatively, select the instance you wish to delete and press the “Delete” button in the tool bar of the “Instance View”.

2.6.3. Moving Instances

You can move the instances of a concept by selecting from the “Move” context menu or by “dragging & dropping” from one concept to another. There you can choose whether to remove inconsistent properties of this instance as well removing inconsistent properties from other instances that also refer to the moved instance.
2.6.4. Properties of Instances

You can change the properties of an instance in the “Properties View”.

If not already shown, you can open this view by Window > Show View > Other... > General > Properties from the window menu. The “Properties View” displays two columns. The first shows available attributes and relations. The second displays the values of these attributes and relations and lets you modify, delete or add values.

Each instance has an “#id”-property, which is the unique identifier, consisting of a namespace and the name of the instance.

To change the value of one of the properties, click on its cell at the “Value” column. If the selected property is an attribute/relation with a max cardinality of 1, you can enter the value directly into the cell. If its max cardinality is greater than 1, a multi-selection dialog opens, where you can enter/select multiple values.
The “Matching Instances” list shows the instances which are possible fillers for the relation. The list can be filtered by typing a letter into the “Select instances” field to display instances starting with the given letter. To add an instance to the property, click on the matching instance and transfer it with **add** to the “Selected instances” list.

### 2.7. Namespace Handling

The default namespace of an ontology will be used when creating new ontology objects and can be changed for each object individually later. You can change the default namespace for an ontology in the entity property view of the ontology (after selecting the ontology in the ontology navigator).

### 2.8. Synonym View

In the synonym editor you can add a list of synonyms for concepts to re-use them in a search scenario (e.g. with “SemanticMiner”). To open the “Synonym View” go to **Window > Show View > Other... > OntoStudio > Synonyms**.
Select the concept you want to extend with synonyms in the “Ontology Navigator”, the synonym view will update. By clicking on the synonyms cell in the “Synonym View”, an editor appears where new synonyms can be entered or existing synonyms can be edited.

“Synonym Editor”
3. Visualizing Ontologies

3.1. Ontology Graph Visualize View

The “Ontology Graph Visualize View” displays the ontology and all elements of the hierarchy (concepts, relations, attributes, instances) in a graph. The values of attributes and relations of instances are not visualized. In the Ontology Navigator you can right click on the ontology you want to visualize and select “Visualize Ontology”. Alternately, right click on a single concept which you want to visualize and select “Show in Visualizer”.

The “Ontology Graph Visualizer View” will open, displaying the selected ontology or concept.
3.1.1. Concept in Focus

Clicking on a concept in the visualizer moves this element into the focus of the view and displays all adjacent elements, i.e. relations and attributes, as well as sub- and super-concepts. The depth of the sub-concept hierarchy displayed in the graph can be configured in the menu Window > Preferences… > OntoVisualize Preferences.

3.1.2. Navigation history

At the bottom of the view, a history of the last selected graph element is displayed. By clicking on one of the elements here, the visualizer jumps back to the previous state. Moving to the previous or next state is also possible by using the arrow icons in the top pane.

3.1.3. Legend

At the left side of the view a legend is displayed explaining the icons used in the diagram. Here you can activate or deactivate different ontology entities by ticking the appropriate checkboxes.

3.1.4. Graph elements

- **Concepts** are represented by blue circles, labelled with a C.
- **Attributes** are represented by orange circles labelled with an A.
- **Relations** are represented by red circles labelled with an R.
- The **ontology** is represented by a colourful icon consisting of tiny versions of the above three icons.
- **Instances** are represented by light-blue circles labelled with an I.
- Grey arrows represent the **concept hierarchy**, i.e. connections between super- and sub-concepts or root-level concepts and the ontology node. The arrowheads always point to super-concepts or the ontology node.
- Orange edges represent the connection between concepts and **attributes**.
- Red arrows represent the connection between concepts and **relations**. A solid arrow points
from the domain concept to the relation node and a dashed line refers to the range concept, which is also identified with a little crosshairs icon.

- Light blue edges connect instance nodes with their concept nodes,

### 3.1.5. Other Functions

The visualizer also provides a **search feature**. Once a concept name is entered, the visualizer searches for this concept in the current diagram and, once found, it is brought into focus. The search is restricted to concepts and requires an exact match to successfully retrieve nodes.

In the preferences of the visualizer (**Window > Preferences… > OntoVisualize Preferences**) you can switch on two more features:

- Usually only direct attributes and relations of the concept in focus are displayed. Ticking the checkbox “Display inherited attributes/relations” overwrites this and will also display properties that are inherited by this concept.
- The checkbox “Display attributes/instances of range concepts and sub concepts” is responsible for adding also more detailed information for other concepts than the one in the focus.

The visualizer’s context menu provides additional functionality, like zooming in and out or rotating the whole graph.

![Context menu of the “Ontology Graph Visualize View”](context_menu.png)

- **Zoom In**
- **Zoom Out**
- **Rotates Clockwise**
- **Rotates Counter Clockwise**
- **Start Layouter**
- **Stop Layouter**

It also allows you to stop the automatic layout algorithm and keeps all nodes at exactly the position where they are manually moved with the mouse.

### 3.2. Graph View

The “Graph View” provides printing functionality and allows exporting of a simple ontology graph as a PDF document. Its main features are:

- Printing the concept graph
- Zooming in and out of the concept graph
- Displaying synonyms in the “Graph View”
- Searching for text in the “Graph View”

By clicking on the context menu of a concept in the “Ontology Navigator”, you can open the “Generate Graph…” function. The selected concept and all its sub-concepts will be displayed in the “Graph View”.

![NeOn](neon.png)
Select “Graph View”

In the setting window you can select four different templates to visualize the graph diagram.

- Concept tree: Display of the hierarchic concept taxonomy
- Concept tree with synonyms: Display of the hierarchic concept taxonomy with synonyms
- Concept graph: Display the ontology with multiple inheritance
- Concept graph with synonyms: Display the ontology with multiple inheritance and the synonyms

The variants with multiple inheritances will display concepts with multiple super-concepts only once thus creating a graph structure. The other variants will duplicate concepts with more than one super-class and mark all but one occurrence as duplicates.

“Graph View with Template Concept Graph”

The icons in the top-right or the context menu entries let you print the graph, or save it as PDF or PNG. Also you can zoom in and out and search for concepts. In this view only hierarchical information is present, i.e. no relations, attributes or instances are available.
4. Rules

Domain models usually contain ontological knowledge and can be extended by adding rules with explanations, which represent complex knowledge going beyond the more structural properties of the ontology. Rules in general have a structure as follows:

IF {the precondition is valid} THEN {the conclusion is valid as well}

The precondition is called the *if-section or body* of the rule. The conclusion is called the *then-part or head* of the rule. In order to specify a valid rule both parts are needed: body and head. Thus, it is necessary to specify which diagram elements are part of the rule body and which are part of the rule head. In the rule diagram, head elements are displayed in green, body elements are displayed in grey.

Rules are only supported by the extended configuration of NeOn Toolkit and are not available in the basic version.

4.1. Creating a Rule

Right mouse click to the “Rules” folder of the Ontology Navigator and select the “New Rule” entry. You can change the proposed random name.

4.2. Entity Property View for Rules

To switch to the Graphical Rule Editor (GRE), click on a rule in the “Ontology Navigator”. This action opens the “Entity Properties View” where the GRE is displayed for the corresponding rule. The chosen rule will be displayed with name, namespace and the rule diagram.
Clicking on the “Rule” tab on the bottom will activate the textual rule editor. Clicking on the “Diagram” tab will activate the graphical editor again.

Use the Fix button in the top right corner to make the GRE view “sticky” – this will keep the rule displayed, even if you select other elements from the ontology navigator. This is needed for dragging and dropping concepts or instances into the graphical editor. By unselecting the Fix icon the entity property view will automatically update according to the selected elements in the ontology navigator again.

4.3. Textually Editing Rules

The Rule tab displays a textual representation of the rule in F-Logic.
Clicking on the button **Textual Edit...** opens an editable text field where the F-Logic representation of the rule can be modified.

The Graphical Rule Editor does not support arbitrary F-Logic rules. This means that some rules must be formulated textually and cannot be displayed correctly with the graphical view. Rules that make use of function symbols, or contain complex first order formulas in the rule body are examples of rules not supported by the graphical representation.

For a full description of the F-Logic Syntax and Semantics refer to the ontoprise web-site [www.ontoprise.de](http://www.ontoprise.de).
4.4. Graphical Rule Editor

4.4.1. Overview

The main means for creating and modifying existing rules is the Graphical Rule Editor (GRE). It enables you to formulate rules in a graphical, interactive way. In the following we show how rules can be modelled with the help of the GRE. These example rules use the field of books, their topics, publishers and authors to illustrate the GRE and provide an insight into the modelling process which should familiarize you with the major functions of the GRE.

On the left side of the GRE you find the palette with several text buttons that provide the functionality of the GRE.

![Graphical representation of a rule in its “Entity Properties View”](image)

4.4.2. Adding Concepts and Instances to the GRE

To add a concept node or an instance to the rule diagram simply “Drag & Drop” it from the “Ontology Navigator” or from the “Instance View” into the GRE. The new node appears in the diagram where you dropped it.

Make sure the diagram is sticky, i.e. the pin-icon in the top right corner of the rule entity property view is selected.

4.4.3. Adding Attributes to the GRE

To add attribute nodes to the diagram choose “Attribute value” from the palette menu and click into the diagram to create an empty attribute node. Fill in desired values and connect the attribute node with the corresponding concept by adding a connection and selecting the name of the desired attribute. Attribute nodes support the following data types: “boolean”, “datetime”, “time”, “date”, “number”, “integer”, and “string”.

4.4.4. Adding Predicates to the GRE

For adding predicate nodes to the diagram choose the “Predicate” entry from the palette menu, then click into the diagram to create a preliminary predicate node. By clicking on the label of the
node a drop down list appears, which lets you choose the desired built-in predicate with the appropriate number of arguments.

![The selection list of a predicate]

For every argument of the predicate a square appears on the top of the predicate. These anchors serve to connect the predicate with the rest of the rule diagram. By adding a connection between the anchor and other elements of the diagram, such as instances or attribute values, the arguments of the predicate are bound.

A complete list of the built-in predicates is presented in the [OntoBroker User Guide](#).

### 4.4.5. Adding Relations or Attributes to the GRE

Two concept nodes can be linked with a connection. This connection represents a relation between instances of the respective concepts. To establish such a relation, select the “Connection” element from the palette menu, then click on the source and the target concept to introduce a new directed connection into the diagram. The label of the connection can be changed to represent the actual semantics of the relation. When the label is selected, a drop down list appears containing all valid relations. A relation is valid if the ontology defines the source concept as the domain and the target concept as the range of this relation. Inheritance is also considered when computing the list.

Attribute edges are created in exactly the same way as relations. The only difference is that the target must be an attribute value node, not a concept node. Also, attribute connections contain comparators at the end where the value node is located that specify the semantics of the link. These comparators are available: $=, <, >, !=, \leq, \geq$.

![Choosing the comparator of an attribute connection]

If the comparator reads “$<$”, and the value reads 24 then the attribute edge of the diagram above reads “If the battery provides amperage less than 24...”.

### 4.4.6. Adding a Comparison

Comparison edges simply express equality or inequality of two nodes. They can be established via the “Comparison” button of the palette. They are created in the same way as attribute or relation links but their label does not come from the ontology but from the set $\{=, <, >, !=, \leq, \geq\}$. Comparison
edges are only valid in the body of a rule and, thus, specify additional conditions. They can also be used to specify that two concept nodes actually represent the same instance.

### 4.4.7. Specifying Head and Body Parts

A rule always consists of conditions and conclusions. The precondition is also called *if-section or body* of the rule. The conclusion is also called *then-part or head* of the rule. In order to specify a valid rule both parts are needed: body and head. Thus, it is necessary to specify which diagram elements are part of the rule body and which are part of the rule head. In the rule diagram, head elements are displayed in green, body elements are displayed in grey.

Relation or Attribute edges as well as concept nodes can be moved from the body to the head and vice versa. To do so, select the element, open the context menu and choose *Toggle If-Then-section*. The element should change its colour from grey to green or vice-versa.

Attribute-value nodes, predicated nodes and comparison arcs cannot be moved to the head of rules.

### 4.4.8. Negations

Sometimes it is necessary to express conditions that do not hold. This can be done by selecting a rule element (which must be in the body of the rule), opening the context menu and choosing *Toggle negation*. Negated elements are represented in red.

### 4.4.9. The Palette Menu

The editing tools for the GRE are provided in the palette menu.

#### Menu “Palette”

- **Namespaces on**: Switches the presentation of the “Namespace-Prefixes” on and off. Namespaces are displayed for concept and property names, and also for instances nodes.
- **Modules on**: Switches the presentation of the “Module-Prefixes” on and off. Each F-Logic-Statement refers to a module. Usually this information is not relevant, because only one module is used. For example, in cases where information from more than one module is integrated, this module-information is very relevant. Module information is available for concept and predicate-nodes, as well as for attribute and relation arcs.
- **Variables on**: Switches the presentation of “Variables” on and off. If off, all variables are implicit only. If on, variables representing the instances of concepts (in concept nodes) are explicitly shown in the diagram.
- **Select**: Activates the mouse selector.
- **Comparison**: Activates the comparison selector to draw comparison arcs (\(=\), \(<\), \(>\), \(!=\), \(\leq\), \(\geq\)) between two concepts nodes.
- **Connection**: Activates the connection selector to draw attribute and relation arcs between concept nodes or between concept and attribute nodes.
- **New Component**: Shows / hides the node types on the bottom of the palette.
- **Attribute value**: Lets you create new, empty attribute value nodes in the rule graph.
- **Predicate**: Lets you create new predicate nodes in the rule graph.

### 4.4.10. The Context Menu

With a right mouse-click on any element in the GRE diagram, a context menu opens, containing the following entries:

![Workflow functions of the GRE desktop](image)

- **Undo**: Undo the last operation
- **Redo**: Redo the last operation
- **Delete**: Remove the selected element(s) and possible incoming and outgoing arcs
- **Edit**: Edit the selected element, only active for connections, attribute values, and predicates
- **Toggle Negation**: Operation to negate the selected elements, i.e. concept nodes, attribute or relation arcs or predicate nodes. Negated elements are displayed in red.
- **Toggle If-/Then-section**: You can mark elements to be part of the rule body or head. Elements in the body (if-section) represent preconditions of the rule. Head-elements (in the then-section) define the results of a rule, i.e. statements that are derived by this rule. Body-elements are marked in grey. Rule elements in the head are represented in green.
- **Connections**: Create a new connection arc.
- **Attribute value**: Create a new attribute value node.
- **New Predicate**: Create a new predicate node.
4.5. Stylized English View

The Stylized English View shows a natural language-like representation of the rule diagram currently shown in the Graphical Rule Editor. It can be used to read aloud and verify the contents of the rule diagram. If the view is not visible go to Window > Show View > OntoStudio > Stylized English View to display it.
5. Sample Walkthrough

In this section we will build a small ontology about cars, their prices and sales regions and will give an insight into the ontology design process. It will get you in touch with the essential functions of NeOn Toolkit.

If you do not want to create the basic elements you can load a prebuilt demo ontology Demo_basic_model_cars_en.oxml that you can find in the installation folder under examples\oxml.

5.1. First Steps

Before starting with the actual modelling we must set up the environment properly:

- Start NeOn Toolkit with a click on the desktop icon or via the Windows start menu.
- Ontologies always reside within a so-called ontology-project. To set up a new project select File > New > Project … from the menu-bar.

Creating a new project

- In the “New Project” window select Ontology and then Ontology Development Project.

Creating a new Ontology Development Project

- Clicking on the Next button opens the window to create a new ontology project.
- Here enter the name “cars” as the project name. You may of course enter an alternative name or the default one. This example will use the project name “cars”.
- To create the project click on the Finish button.
Before you can import or create an ontology you have to create a project, especially if NeOn Toolkit has been installed anew.

The “Ontology Navigator” now shows the new ontology project. We will now set up an ontology in this project.

5.2. Creating a New Ontology

In order to create a new ontology in NeOn Toolkit proceed as follows:

- Using the right mouse button, click on the project name in the “Ontology Navigator” and in the context menu select *New Ontology*.

- In the “New Ontology” window you can now indicate a “Module Identifier” (the *name of the ontology*) and a “Default Namespace”. The proposed default values are sufficient for the purposes of our sample. You can change them now if you want.

- The “Module Identifier” is used for unique identification of modules. Modules divide the knowledge base in smaller units to ensure that the units do not influence each other unintentionally. Thus, the module is equivalent to the notion of an ontology.

- After clicking on the “Finish” button you have now created a new, empty ontology. Note that the ontology is now displayed in the ontology navigator with empty folders for concepts, attributes, rules etc.
5.3. Creating New Concepts

The next step is creating the concept “product” as well as its sub-concept “car” and the sub-concepts of “car”: “Audi A2”, “Audi A3” and “Audi A4”.

- Open the entire structure of the ontology (click on the plus signs of the ontology) in the “Ontology Navigator” window.
- With the right mouse button, click on the “Concepts” folder and select “New Concept” in the context menu.
- In the “Ontology Navigator” window the default name of the concept, e.g. “term1103116866533” appears within the “Concepts” folder. Now change this name to a proper name, such as “product”.

You can modify the concept name at any time by using the Entity Property View (the top right area on the screen).

- With the right mouse button, click on the concept “product” and from the context menu select “New Concept”.
- A new concept with a default name is now located under the “product” concept. This indicates that the new concept is a sub-concept of “product”. Change the concept name to “car”.
- With the right mouse button, click on the concept “car” and from the context menu select “New Concept”.
- Another new concept with a default name now appears under the “car” concept, representing a sub-concept of car. Change the concept name to “Audi A2”.
- Repeat these steps in order to create concepts “Audi A3” and “Audi A4” as sub-concepts of “car”.
- Whenever a word contains an umlaut (e.g. the “ü” in German “Reiseführer”), a space character (such as in “Audi A4”), or any other non-word character the concept name will be enclosed in quotation marks.
- Next, we create the concepts “region”, “sales” and “price” as root concepts:
  - With the right mouse button click on the “Concepts” folder and select “New Concept” from the context menu.
  - Enter “region” as the concept name and repeat this process also for “sales” and “price”.
- Finally create “continent” and “country” as sub-concepts of the “region” concept.

After this process the structure of the ontology in the “Ontology Navigator” should look like this (for better readability, the namespaces are deactivated):
5.4. Multilingual Representations

Each concept can have representations in multiple languages. To create a German representation for the concept names enter them in the appropriate column of the “Representations” table of the “Entity Property View” of the individual concepts.

<table>
<thead>
<tr>
<th>Representations</th>
<th>de</th>
<th>en</th>
<th>fr</th>
</tr>
</thead>
<tbody>
<tr>
<td>Produkt</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

German representation “Produkt” for the concept “product”

### Table 6 - Sample Multilingual representations

<table>
<thead>
<tr>
<th>concept</th>
<th>de</th>
<th>en</th>
<th>fr</th>
</tr>
</thead>
<tbody>
<tr>
<td>product</td>
<td>“Produkt”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>region</td>
<td>“Region”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>sales</td>
<td>“Vertrieb”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>price</td>
<td>“Preis”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>car</td>
<td>“Auto”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>continent</td>
<td>“Kontinent”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>country</td>
<td>“Land”</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

5.5. Creating Attributes

The main distinction between attributes and relations is the type of their values. Attributes always have atomic values and thus are identical to OWL-data type properties. Relations always refer to instances and thus are equivalent to OWL-object properties.

Attributes and relations are defined for concepts in an object-oriented sense. They are, therefore, created and modified in the context of a concept within the concept’s “Entity Property View”.
Properties (attributes and relations) of the concept “region”

First we want to define an attribute “hasName” for products. In order to set up this attribute, proceed as follows:

- Enter “hasName” in the “Entity Property View” of the “product” concept in the “Attribute” column under the section “Attributes”.
- Enter “string” in the properties window of the “product” concept in the “Range” column under the section “Attributes” (or just type “s” and select “string” from the appearing list).
- Thus the property “hasName” is assigned to the concept “product” (and thereby all sub-concepts such as “car”). The changes are automatically stored which means that the new attribute also appears in the “Attributes” folder of the “Ontology Navigator”.
- To verify that the attribute is inherited by “car” click on the “car” concept to open its “Entity Property View”. Here we see the same definition of “hasName” as for “product”. But now it has a grey background and cannot be modified.

To practice the creation of attributes you could define this knowledge:

- Region: hasName=>string
- Sales: amount=>integer
- Price: value=>number

5.6. Creating Relations

The connections between instances are represented with “relations”. They are quite similar to attributes and are essentially created and maintained in exactly the same way. The first example we create is the relationship between regions. Each region can be part of another region, e.g. Germany is part of Europe.

- Select the “region” concept in the “Ontology Navigator”.
- In the “Entity Property View” of “region” enter “partOf” in the column “Relation” under the section “Relations”. Choose “region” as the range of the relation. The changes are stored automatically and now the new relation appears in the “Relations” folder of the “OntologyNavigator”.
- Relations are also inherited by sub-concepts. Verify this by checking the sub-concepts “continent” and “country”.

```
To practice the creation of relations you could define this knowledge:

- Region: partOf=>region
- Sales: ofProduct=>product; inRegion=>region
- Price: ofProduct=>product; inRegion=>region

5.7. Setting up Instances

Using the above steps we have now created an ontology, i.e. a concept hierarchy with logical connections. Instances are concrete entities of concepts, e.g. “Europe” is an instance of the concept “continent”. To create instances we use the “Instance View”. It is shown below the “Ontology Navigator” window.

- First choose the concept you want to create a new instance for in the “Ontology Navigator”, here: the concept “continent”.
- Click on the symbol “Create a new instance” in the header of the “Instance View”. A new instance is created.
- An arbitrary name is suggested which you can change immediately. Enter “Europe” as the name of the instance.
- In the “Properties” window to the right all potential properties of the instance are listed. Here you can fill in the correct value for the attribute field “hasName”.
- Repeat these steps to set up more instances of the concepts “continent” and “country”.

5.8. Moving a Concept

To rearrange concepts in the concept hierarchy you can move these around. Right-click on the concept and choose the “Refactor” menu to move an element.
Menu – Moving a concept

If you click on “Move…” a window will open for you to select the target concept. Alternatively, you can drag and drop a concept to its new parent (super-concept or concept folder).

“Move concepts” dialog to choose the target concept

The check box lets you choose whether inconsistent instance properties should be removed. When moving a concept, all its instances will also move with it in the concept tree. Since instances carry real values (including values for inherited properties) some of them might not be valid after the move. By ticking the check-box all obsolete property values will be removed. Otherwise they are retained and will represent inconsistent instances with respect to the information from the ontology.